Processing disrupted
Incident Report for bken
Resolved
This incident has been resolved.
Posted Jul 21, 2020 - 05:03 UTC
Update
A fix has been deployed and the system is recovering
Posted Jul 21, 2020 - 05:03 UTC
Investigating
We are currently investigating this issue.
Posted Jul 21, 2020 - 04:59 UTC
This incident affected: Media Processing (Detroit).